Browse Source

Update dependencies

Signed-off-by: Graham <gpe@openrs2.org>
master
Graham 1 month ago
parent
commit
405603f2f4
  1. 16
      gradle/libs.versions.toml
  2. 6
      settings.gradle.kts

16
gradle/libs.versions.toml

@ -5,11 +5,11 @@ guava = "30.1.1-jre"
guice = "5.0.1"
jackson = "2.12.5"
jimfs = "1.2"
junit = "5.7.2"
junit = "5.8.0"
kotlin = "1.5.30"
kotlinCoroutines = "1.5.2"
ktor = "1.6.3"
netty = "4.1.67.Final"
netty = "4.1.68.Final"
nettyIoUring = "0.0.8.Final"
[libraries]
@ -24,9 +24,9 @@ bouncyCastle-provider = { module = "org.bouncycastle:bcprov-jdk15on", version =
byteUnits = { module = "com.jakewharton.byteunits:byteunits", version = "0.9.1" }
clikt = { module = "com.github.ajalt.clikt:clikt", version = "3.2.0" }
commons-compress = { module = "org.apache.commons:commons-compress", version.ref = "commons-compress" }
fastutil = { module = "it.unimi.dsi:fastutil", version = "8.5.4" }
fastutil = { module = "it.unimi.dsi:fastutil", version = "8.5.6" }
fernflower = { module = "org.openrs2:fernflower", version = "1.1.1" }
flyway = { module = "org.flywaydb:flyway-core", version = "7.14.1" }
flyway = { module = "org.flywaydb:flyway-core", version = "7.15.0" }
guava = { module = "com.google.guava:guava", version.ref = "guava" }
guice = { module = "com.google.inject:guice", version.ref = "guice" }
h2 = { module = "com.h2database:h2", version = "1.4.200" }
@ -41,17 +41,17 @@ jgrapht = { module = "org.jgrapht:jgrapht-core", version = "1.5.1" }
jimfs = { module = "com.google.jimfs:jimfs", version.ref = "jimfs" }
jquery = { module = "org.webjars:jquery", version = "3.6.0" }
jsoup = { module = "org.jsoup:jsoup", version = "1.14.2" }
junit-api = { module = "org.junit.jupiter:junit-jupiter-api", version = { strictly = "5.7.2" } }
junit-api = { module = "org.junit.jupiter:junit-jupiter-api", version = { strictly = "5.8.0" } }
junit-engine = { module = "org.junit.jupiter:junit-jupiter-engine", version.ref = "junit" }
junit-launcher = { module="org.junit.platform:junit-platform-launcher", version = "1.7.2" }
junit-launcher = { module="org.junit.platform:junit-platform-launcher", version = "1.8.0" }
kotlin-coroutines-core = { module = "org.jetbrains.kotlinx:kotlinx-coroutines-core", version.ref = "kotlinCoroutines" }
kotlin-coroutines-test = { module = "org.jetbrains.kotlinx:kotlinx-coroutines-test", version.ref = "kotlinCoroutines" }
kotlinPoet = { module = "com.squareup:kotlinpoet", version = "1.9.0" }
kotlinPoet = { module = "com.squareup:kotlinpoet", version = "1.10.0" }
ktor-jackson = { module = "io.ktor:ktor-jackson", version.ref = "ktor" }
ktor-server-cio = { module = "io.ktor:ktor-server-cio", version.ref = "ktor" }
ktor-thymeleaf = { module = "io.ktor:ktor-thymeleaf", version.ref = "ktor" }
ktor-webjars = { module = "io.ktor:ktor-webjars", version.ref = "ktor" }
logback = { module = "ch.qos.logback:logback-classic", version = "1.2.5" }
logback = { module = "ch.qos.logback:logback-classic", version = "1.2.6" }
netty-buffer = { module = "io.netty:netty-buffer", version.ref = "netty" }
netty-codec-core = { module = "io.netty:netty-codec", version.ref = "netty" }
netty-codec-http = { module = "io.netty:netty-codec-http", version.ref = "netty" }

6
settings.gradle.kts

@ -15,9 +15,9 @@ pluginManagement {
id("com.github.ben-manes.versions") version "0.39.0"
id("com.github.jk1.dependency-license-report") version "2.0"
id("com.github.johnrengelman.shadow") version "7.0.0"
id("org.jetbrains.dokka") version "1.5.0"
id("org.jmailen.kotlinter") version "3.5.1"
kotlin("jvm") version "1.5.30"
id("org.jetbrains.dokka") version "1.5.30"
id("org.jmailen.kotlinter") version "3.6.0"
kotlin("jvm") version "1.5.31"
}
}

Loading…
Cancel
Save